Q1:通达信软件rsi 回落到50附近选股公式。跪求,谢谢。

{通达信软件RSI 回落(即今天RIS比昨日RSI低)到50附近(即6,12,24均≥50且又都小于55)}

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;

RSI1<REF(RSI1,1) AND

RSI2<REF(RSI2,1) AND

RSI3<REF(RSI3,1) AND

RANGE(RSI1,50,55) AND

RANGE(RSI2,50,55) AND

RANGE(RSI3,50,55);

Q2:通达信RSI公式,请编个rsi1下穿rsi3的选股公式,谢谢了

{参数N1=6; N2=12; N3=24;}
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
CROSS(RSI3,RSI1)

Q3:通达信选股公式,求RSI1连续20天小于50选股公式。

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
XG:COUNT(RSI1<50,20)=20;

Q4:求助!!通达信RSI背离选股公式

底背离可以用很多种方法认定,例如用时间,也就是第一段时间的和第二段时间中rsi指标最低值在上升,价格同时期在下降,还有是两次死叉过程中产生的低点做对比,发现背离.
背离是一种形态分析的方法
想把背离编辑成选股公式,需要你先确认你是如何判断背离标准的.把判断的方法转换成具体的条件.
例如图中的rsi背离划线指标.是根据两次死叉时发生的最低点判断的,在金叉发生时,提示前面产生过背离.
图片中就的效果就是


如果有什么疑问可以私信联系我.

黄色箭头是差值大于10 白色箭头是单纯比大小

参数n是最近几日除以除以2的结果,如果是最近6日参数就填3就行了

N:=3;
XG1:LLV(RSI.RSI1,N)>REF(LLV(RSI.RSI1,N),N-1) AND LLV(L,N)<REF(LLV(L,N),N-1);
XG2:LLV(RSI.RSI1,N)-REF(LLV(RSI.RSI1,N),N-1)>10 AND LLV(L,N)<REF(LLV(L,N),N-1);

想用哪个就把另一个冒号后加个等号就可以了

这种背离判断过于简单,准确率没测过不知道

Q5:我用的是通达信行情分析软件,请高手编写一个【肯特纳通道】的公式,谢谢了!

{肯特纳通道}
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TR1,M1);
K_MID:EMA(C,M2),COLOR4E2F2F;
K_UP:K_MID+2*ATR,COLOR4E2F2F;
K_LO:K_MID-2*ATR,COLOR4E2F2F;

Q6:通达信公式如何编写均线上下通道满足100个周期的K线95%在通道内?

那就统计一下100周期内,最高价小于等于通道上轨道,最低价大于等于通道下轨的,的k线数量大于等于95不就可以了吗?
以ENE通道指标为例公式如下.
UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
XG:COUNT(H<=UPPER AND L>=LOWER,100)>=95;